On Tue, 2 Aug 2005, David Jencks wrote:
> I'm sorry, but I can't understand what you are proposing.  Can you 
> provide a schema fragment for the elements you want to change?

Old:

<xsd:element name="port" type="gernaming:portType" maxOccurs="unbounded"/>
...
<xsd:element name="port" type="gernaming:port-completionType" 
maxOccurs="unbounded"/>
...
<xsd:complexType name="port-completionType">
    <xsd:complexContent>
        <xsd:extension base="gernaming:portType">
            <xsd:sequence>
                <xsd:element name="binding-name" type="xsd:string"/>
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>

New:

<xsd:element name="port" type="gernaming:portType" maxOccurs="unbounded"/>
...
<xsd:element name="port-completion" type="gernaming:port-completionType" 
maxOccurs="unbounded"/>
...
<xsd:complexType name="port-completionType">
    <xsd:sequence>
        <xsd:element name="port" type="gernaming:portType"/>
        <xsd:element name="binding-name" type="xsd:string"/>
    </xsd:sequence>
</xsd:complexType>

For further clarification, look at 
http://chariotsolutions.com/geronimo/images/geronimo-openejb-serviceref.png
and observe how the top "port" element and the bottom "port" element have 
slightly different content.

Aaron

> On Aug 2, 2005, at 5:19 PM, Aaron Mulder wrote:
> 
> >     So our our naming schema, when dealing with web services, has an
> > unfortunate overlap with two different "port" elements that are 
> > subtlely
> > different:
> >
> > <service-ref>
> >   <service-ref-name />
> >   <service-completion>
> >     <service-name />
> >     <port> (def #1, portCompletionType)
> >       (contents of port #2)
> >       <binding-name />
> >     </port>
> >   </service-completion>
> >   <port>  (def #2)
> >     ...
> >   </port>
> > </service-ref>
> >
> >     In other words, the first "port" element contains all the same
> > stuff as the second "port" element plus one extra element.
> >
> >     I think it would be preferable to have what's currently the first
> > "port" look like this:
> >
> > <port-completion>
> >   <port ... />
> >   <binding-name />
> > </port-completion>
> >
> >     That way both "port" elements would be identical.
> >
> >     Any objections to making this change in M5?
> >
> > Thanks,
> >     Aaron
> >
> 
> 

Reply via email to