On 11 June 2014 at 4:11:32 am, Peter Ledbrook (pe...@cacoethes.co.uk) wrote:
> We probably want something closer to: > > buildLogic { > plugin “org.gradle.java” > library “commons-collections:commons-collections:1.2.3" > } This raises the question of why not just use buildscript {}? Simpler to understand if there is a clean break, and the term ‘buildscript’ isn’t very meaningful. Are the repository definitions for resolving plugins and JARs still supposed to go into the buildscript {} block, or should they go in buildLogic {}? They will be somewhere else entirely. Scripts declare what they need in terms of identity, how that is mapped to an implementation is the business of something else. Also, can build files in sub-projects now have their own buildscript {} blocks? They’ve always been able to. One other option is for the plugins {} block to be something like an alias to plugin declarations in buildscript {}. So buildscript {} would still be the authority, but you just include a shortcut for convenience. Not big on this. The way we use buildscript {} is broken and we need to work towards removing it. Part of the new system is that plugins are isolated and class paths are not inherited. Peter -- Peter Ledbrook t: @pledbrook --------------------------------------------------------------------- To unsubscribe from this list, please visit: http://xircles.codehaus.org/manage_email — Luke Daley Gradleware Join us for Gradle Summit 2014, June 12th and 13th in Santa Clara, CA: http://www.gradlesummit.com