-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/66571/#review201144
-----------------------------------------------------------




common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
Lines 4203 (patched)
<https://reviews.apache.org/r/66571/#comment282155>

    needs rename to "hive." here as well



metastore/scripts/upgrade/hive/hive-schema-3.0.0.hive.sql
Lines 1085 (patched)
<https://reviews.apache.org/r/66571/#comment282157>

    I think its easier to reason about the correctness of this one if you put 
another set of paranthesis around the group match condition-
    
    OR ((array_contains(current_groups(), P.`PRINCIPAL_NAME`) OR 
P.`PRINCIPAL_NAME` = 'public') AND P.`PRINCIPAL_TYPE`='GROUP'))
    
    Otherwise, it seems like it might get reduced to something like -
    
    P.`PRINCIPAL_TYPE`='USER' OR (array....) AND P.`PRINCIPAL_TYPE`='GROUP'



metastore/scripts/upgrade/hive/hive-schema-3.0.0.hive.sql
Lines 1120 (patched)
<https://reviews.apache.org/r/66571/#comment282156>

    similar parenthesis would be useful here



metastore/scripts/upgrade/hive/hive-schema-3.0.0.hive.sql
Lines 1152 (patched)
<https://reviews.apache.org/r/66571/#comment282158>

    similar parenthesis would be useful here



metastore/scripts/upgrade/hive/hive-schema-3.0.0.hive.sql
Lines 1309 (patched)
<https://reviews.apache.org/r/66571/#comment282159>

    similar parenthesis would be useful here



metastore/scripts/upgrade/hive/hive-schema-3.0.0.hive.sql
Lines 1345 (patched)
<https://reviews.apache.org/r/66571/#comment282161>

    similar parenthesis would be useful here



metastore/scripts/upgrade/hive/hive-schema-3.0.0.hive.sql
Lines 1382 (patched)
<https://reviews.apache.org/r/66571/#comment282160>

    similar parenthesis would be useful here



service/src/java/org/apache/hive/service/server/HiveServer2.java
Lines 141 (patched)
<https://reviews.apache.org/r/66571/#comment282164>

    typo, rename variable to -
    zooKeeperClientForPrivilegeSynchronizer
    
    or shorter -
    zKClientForPrivSync



standalone-metastore/src/main/thrift/hive_metastore.thrift
Lines 1997 (patched)
<https://reviews.apache.org/r/66571/#comment282177>

    Update the description ? 
    // Revokes all privileges for the object and adds the newly granted 
privileges for it.


- Thejas Nair


On April 13, 2018, 10:30 p.m., Daniel Dai wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/66571/
> -----------------------------------------------------------
> 
> (Updated April 13, 2018, 10:30 p.m.)
> 
> 
> Review request for hive.
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> See HIVE-19161
> 
> 
> Diffs
> -----
> 
>   common/src/java/org/apache/hadoop/hive/conf/HiveConf.java 0627c35 
>   
> itests/hcatalog-unit/src/test/java/org/apache/hive/hcatalog/listener/DummyRawStoreFailEvent.java
>  801de7a 
>   itests/hive-unit/pom.xml f473d25 
>   
> itests/hive-unit/src/test/java/org/apache/hive/service/server/TestInformationSchemaWithPrivilege.java
>  PRE-CREATION 
>   
> jdbc-handler/src/main/java/org/apache/hive/storage/jdbc/dao/DatabaseAccessorFactory.java
>  7dc690f 
>   
> jdbc-handler/src/main/java/org/apache/hive/storage/jdbc/dao/GenericJdbcDatabaseAccessor.java
>  178c97d 
>   
> jdbc-handler/src/main/java/org/apache/hive/storage/jdbc/dao/JdbcRecordIterator.java
>  638e2b0 
>   
> jdbc-handler/src/main/java/org/apache/hive/storage/jdbc/dao/MsSqlDatabaseAccessor.java
>  PRE-CREATION 
>   
> jdbc-handler/src/main/java/org/apache/hive/storage/jdbc/dao/OracleDatabaseAccessor.java
>  PRE-CREATION 
>   
> jdbc-handler/src/main/java/org/apache/hive/storage/jdbc/dao/PostgresDatabaseAccessor.java
>  PRE-CREATION 
>   metastore/scripts/upgrade/hive/hive-schema-3.0.0.hive.sql 3444439 
>   ql/src/java/org/apache/hadoop/hive/ql/exec/FunctionRegistry.java d59bf1f 
>   
> ql/src/java/org/apache/hadoop/hive/ql/security/authorization/HiveAuthorizationProvider.java
>  60d9dc1 
>   
> ql/src/java/org/apache/hadoop/hive/ql/security/authorization/PrivilegeSynchonizer.java
>  PRE-CREATION 
>   
> ql/src/java/org/apache/hadoop/hive/ql/security/authorization/plugin/HiveResourceACLsImpl.java
>  PRE-CREATION 
>   ql/src/java/org/apache/hadoop/hive/ql/session/SessionState.java 6003ced 
>   
> ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFCurrentGroups.java
>  PRE-CREATION 
>   
> ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFRestrictInformationSchema.java
>  PRE-CREATION 
>   service/src/java/org/apache/hive/service/server/HiveServer2.java 6308c5c 
>   
> standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
>  450da4f 
>   
> standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/HiveMetaStoreClient.java
>  ebbf465 
>   
> standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/IMetaStoreClient.java
>  b2c40c2 
>   
> standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/ObjectStore.java
>  2056930 
>   
> standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/RawStore.java
>  f6c46ee 
>   
> standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/cache/CachedStore.java
>  c47856d 
>   standalone-metastore/src/main/thrift/hive_metastore.thrift 7450439 
>   
> standalone-metastore/src/test/java/org/apache/hadoop/hive/metastore/DummyRawStoreControlledCommit.java
>  304f567 
>   
> standalone-metastore/src/test/java/org/apache/hadoop/hive/metastore/DummyRawStoreForJdoConnection.java
>  85c6727 
>   
> standalone-metastore/src/test/java/org/apache/hadoop/hive/metastore/HiveMetaStoreClientPreCatalog.java
>  7d37262 
> 
> 
> Diff: https://reviews.apache.org/r/66571/diff/4/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Daniel Dai
> 
>

Reply via email to