Well, instead of getFirst(), I would have getNext(). This way we do not
have to keep the first entry forever, which could present a problem in case
if entry is too large.

As far as initializing keepAll() to false - completely agree.

D.

On Mon, Jul 16, 2018 at 4:43 PM, Alexey Goncharuk <
alexey.goncha...@gmail.com> wrote:

> No objections from my side. Would be nice to receive some feedback from
> other community members, though, because this is formally a breaking
> change.
>
> пн, 16 июл. 2018 г. в 16:40, Yakov Zhdanov <yzhda...@apache.org>:
>
> > Guys, it seems we need to deprecate getAll() and remove it in 3.0. I
> think
> > it is usable only for queries that return 1 row. Every other case needs
> > iteration. So having getFirst() seems to be better. Thoughts?
> >
> > As far as ScanQuery I think we can properly initialize keepAll to false
> on
> > scan query instantiation. I am pretty sure none needs getAll() in scans.
> > Alex?
> >
> > --
> > Yakov
> >
>

Reply via email to