Zoltan Ivanfi has posted comments on this change. Change subject: IMPALA-1659: Netezza compatibility functions: metadata ......................................................................
Patch Set 1: (1 comment) http://gerrit.cloudera.org:8080/#/c/4063/1/be/src/exprs/utility-functions-ir.cc File be/src/exprs/utility-functions-ir.cc: Line 120: StringVal UtilityFunctions::CurrentSid(FunctionContext* ctx) { This function was requested in the feature request, but I feel that it should not be added because of the reasons listed below, please let me know your opinion. There is no documentation available for Netazza's current_sid. The docs linked in the issue attachment are Microsoft's and their current_sid has a different meaning: it stands for Security ID there. Although there are no docs about Netazza's current_sid, there are some examples on the net, for example here: http://stackoverflow.com/questions/27402899/netezza-sql-to-find-client-ip Two things are obvious from this example: - current_sid is not a function, but a magic constant - current_sid is a number, not a string Adding a current_sid function will not provide any Netezza-compatibility, because it won't work without () and our session IDs are strings not numbers (although in theory we could use a different representation of our session ID, but a 128-bits may be too much to return as a number). For this reason I suggest to omit this function. -- To view, visit http://gerrit.cloudera.org:8080/4063 To unsubscribe, visit http://gerrit.cloudera.org:8080/settings Gerrit-MessageType: comment Gerrit-Change-Id: I9b5d1009bbf42acc175a942d2df484e1c64822ca Gerrit-PatchSet: 1 Gerrit-Project: Impala-ASF Gerrit-Branch: master Gerrit-Owner: Zoltan Ivanfi <[email protected]> Gerrit-Reviewer: Zoltan Ivanfi <[email protected]> Gerrit-HasComments: Yes
