Dan Hecht has posted comments on this change.

Change subject: IMPALA-3610: Account for memory used by filters in the 
coordinator
......................................................................


Patch Set 6:

(4 comments)

Don't mean to distract, but have some suggestions for making a bit more 
readable since I had some trouble following the code.

http://gerrit.cloudera.org:8080/#/c/4066/6/be/src/runtime/coordinator.cc
File be/src/runtime/coordinator.cc:

Line 2066:     TBloomFilter* non_const_filter;
rather than defining non_const_filter temporary here, I think it would be 
clearer to define it below inside the if-body, and give it a more descriptive 
name for each case. that would make the code more self-documenting (see 
comments below).


PS6, Line 2068: non_const_filter
this shadows the def at L2066, but as I said above, let's get rid of 2066.  And 
then how about calling this:

TBloomFilter* broadcast_filter = 
&(const_cast<TBloomFilter&>(params.bloom_filter));


Line 2074:       non_const_filter = state->bloom_filter.get();
And then here:

TBloomFilter* aggregated_filter = state->bloom_filter.get();


Line 2085:     state->DiscardFilter(filter_mem_tracker_.get());
Does this do anything in cases #1 and #3, or is it only for case #2 (aggregated 
filters)?


-- 
To view, visit http://gerrit.cloudera.org:8080/4066
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I3c52c8a1c2e79ef370c77bf264885fc859678d1b
Gerrit-PatchSet: 6
Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-Owner: Henry Robinson <he...@cloudera.com>
Gerrit-Reviewer: Dan Hecht <dhe...@cloudera.com>
Gerrit-Reviewer: Henry Robinson <he...@cloudera.com>
Gerrit-Reviewer: Marcel Kornacker <mar...@cloudera.com>
Gerrit-Reviewer: Sailesh Mukil <sail...@cloudera.com>
Gerrit-HasComments: Yes

Reply via email to