[
https://issues.apache.org/jira/browse/ISIS-667?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13891924#comment-13891924
]
ASF subversion and git services commented on ISIS-667:
------------------------------------------------------
Commit 4ce9e812ff6be219cdb1d4ca6df362491ea2f339 in branch refs/heads/master
from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=4ce9e81 ]
ISIS-667,ISIS-684,ISIS-685: async commands, tidy-up
ISIS-684:
- rename BackgroundActionService to BackgroundCommandService
ISIS-667:
- memberIdentifier, targetClass, targetAction, targetStr consistent across
PublishedEventJdo, AuditEntryJdo, CommandJdo
ISIS-685:
- @Command annotation extended, with persistence() and executeIn() attributes
- corresponding updates to CommandFacet
- Command#executor and Command#executedIn keep track of whether being run by
user or background
- ActionInvocationFacetViaMethod new logic, short-circuits execution if
executor = user but executedIn = background,
and return the command instead (if persistable)
- CommandService API extended to allow callers to request persistence of
Command early
(as used by ActionInvocationFacetViaMethod)
> General tidy-up/rationalization of JDO domain service impls
> -----------------------------------------------------------
>
> Key: ISIS-667
> URL: https://issues.apache.org/jira/browse/ISIS-667
> Project: Isis
> Issue Type: Improvement
> Affects Versions: archetype-simple-wrj-1.3.1,
> archtype-quickstart-wrj-1.3.1, objectstore-jdo-1.3.0
> Reporter: Dan Haywood
> Assignee: Dan Haywood
> Fix For: archetype-simple-wrj-1.4.0,
> archetype-quickstart-wrj-1.4.0, objectstore-jdo-1.4.0
>
>
> We now have six implementations of various applib domain services by JDO
> objectstore:
> - auditing service
> - publishing service
> - background task service
> - interaction service
> - appsettings
> - user settings
> This ticket is to rationalize them (in particular the first four, that all
> share a common usage of transactionId)
--
This message was sent by Atlassian JIRA
(v6.1.5#6160)