[ 
https://issues.apache.org/jira/browse/KAFKA-688?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13548886#comment-13548886
 ] 

John Fung commented on KAFKA-688:
---------------------------------

Uploaded kafka-688-v1.patch which is required after checking in the patch in 
KAFKA-648.

The changes include:

1. Updated all testcase_xxxx_properties.json on the following properties keys:
    brokerid => broker.id
    log.file.size => log.segment.size
    groupid => group.id 

2. Added "07_client" property to 
migration_tool_testsuite/testcase_xxxx/testcase_xxxx_properties.json files 
under those brokers running in 0.7 code

3. Modified system_test/utils/kafka_system_test_utils.py to add "brokerid" key 
to server.properties file if the broker is running under 0.7
                
> System Test - Update all testcase_xxxx_properties.json for properties keys 
> uniform naming convention
> ----------------------------------------------------------------------------------------------------
>
>                 Key: KAFKA-688
>                 URL: https://issues.apache.org/jira/browse/KAFKA-688
>             Project: Kafka
>          Issue Type: Task
>            Reporter: John Fung
>            Assignee: John Fung
>              Labels: replication-testing
>         Attachments: kafka-688-v1.patch
>
>
> After the changes made in "uniform naming convention of properties keys" 
> (KAFKA-648), all testcase_xxxx_properties.json files need to be updated on 
> the following properties keys changes:
> brokerid => broker.id
> log.file.size => log.segment.size
> groupid => group.id

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to