[
https://issues.apache.org/jira/browse/KAFKA-755?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Swapnil Ghike updated KAFKA-755:
--------------------------------
Attachment: kafka-755-v2.patch
Addressed all points.
i. Renamed valueAsString flag to valueInQuotes for clarity.
ii. Json fields should appear in sorted order now.
iii. Changed the whitelist/blacklist detection to use the "pattern" field in
the zk json. Accordingly modified the createTopicCount and dbString methods.
Testing done -
1. Testing done for v1 patch.
2. Tried all of non-wildcard, whitelist and blacklist topics with console
consumer. Zk data looks ok (it does not include * for non-wildcard topics).
Also changed the wiki to reflect this, previously it had entries like "*abc"
and "!abc" for wildcard consumer subscription fields.
> standardizing json values stored in ZK
> --------------------------------------
>
> Key: KAFKA-755
> URL: https://issues.apache.org/jira/browse/KAFKA-755
> Project: Kafka
> Issue Type: Bug
> Components: core
> Affects Versions: 0.8
> Reporter: Jun Rao
> Assignee: Swapnil Ghike
> Priority: Blocker
> Labels: p1
> Fix For: 0.8
>
> Attachments: kafka-755-v1.patch, kafka-755-v2.patch
>
>
> Currently, we have the following paths in ZK that stores non-singleton values.
> 1. Topic assignment value:
> /brokers/topics/topic
> { "0": ["0"] }
> 2. LeaderAndISR info:
> /brokers/topics/test/partitions/0/leaderAndISR
> { "ISR":"0,1","leader":"0","controllerEpoch":"1","leaderEpoch":"0" }
> 3. broker registration:
> /brokers/ids/0
> 192.168.1.148:9092:9999
> 4. partition reassignment path
> It would be good if we do the following:
> a. make them true json (e.g., using number as the value for broker/partition,
> instead of string).
> b. add version support for future growth.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira