[
https://issues.apache.org/jira/browse/KAFKA-6821?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Matthias J. Sax resolved KAFKA-6821.
------------------------------------
Resolution: Cannot Reproduce
A lot of work on EOS was done recently. Closing this ticket at it should not be
an issue any longer.
> The producer attempted to use a producer id which is not currently assigned
> to its transactional id
> ----------------------------------------------------------------------------------------------------
>
> Key: KAFKA-6821
> URL: https://issues.apache.org/jira/browse/KAFKA-6821
> Project: Kafka
> Issue Type: Bug
> Components: streams
> Affects Versions: 1.0.0
> Environment: Centos 7
> Reporter: RandySun
> Priority: Trivial
> Labels: eos
>
> I use Kafka Stream to join to KStream,however, I found an error stack trace
> in my application log as below:
> {code:java}
> Aborting producer batches due to fatal error
> org.apache.kafka.common.KafkaException:
> org.apache.kafka.common.errors.InvalidPidMappingException: The producer
> attempted to use a producer id which is not currently assigned to its
> transactional id
> at
> org.apache.kafka.clients.producer.internals.TransactionManager$AddPartitionsToTxnHandler.handleResponse(TransactionManager.java:1037)
>
> at
> org.apache.kafka.clients.producer.internals.TransactionManager$TxnRequestHandler.onComplete(TransactionManager.java:905)
>
> at
> org.apache.kafka.clients.ClientResponse.onComplete(ClientResponse.java:101)
> at
> org.apache.kafka.clients.NetworkClient.completeResponses(NetworkClient.java:482)
>
> at org.apache.kafka.clients.NetworkClient.poll(NetworkClient.java:474)
> at org.apache.kafka.clients.producer.internals.Sender.run(Sender.java:216)
> at org.apache.kafka.clients.producer.internals.Sender.run(Sender.java:163)
> at java.lang.Thread.run(Thread.java:745)
> Caused by: org.apache.kafka.common.errors.InvalidPidMappingException: The
> producer attempted to use a producer id which is not currently assigned to
> its transactional id
> {code}
>
> There is no evidence showing any other error in my application, and the kafka
> controller.log saying
>
>
> {code:java}
> [2018-04-17 17:54:33,212] DEBUG [Controller id=2] Preferred replicas by
> broker Map(2 -> Map(__consumer_offsets-19 -> Vector(2, 3, 1),
> com.randy.Demo1-KSTREAM-FLATMAP-0000000001-repartition-1 -> Vector(2)
> [2018-04-17 17:54:33,212] DEBUG [Controller id=2] Topics not in preferred
> replica Map() (kafka.controller.KafkaController)
> [2018-04-17 17:54:33,212] TRACE [Controller id=2] Leader imbalance ratio for
> broker 2 is 0.0 (kafka.controller.KafkaController)
> [2018-04-17 17:54:33,212] DEBUG [Controller id=2] Topics not in preferred
> replica Map() (kafka.controller.KafkaController)
> [2018-04-17 17:54:33,212] TRACE [Controller id=2] Leader imbalance ratio for
> broker 1 is 0.0 (kafka.controller.KafkaController)
> [2018-04-17 17:54:33,212] DEBUG [Controller id=2] Topics not in preferred
> replica Map() (kafka.controller.KafkaController)
> [2018-04-17 17:54:33,212] TRACE [Controller id=2] Leader imbalance ratio for
> broker 3 is 0.0 (kafka.controller.KafkaController)
> {code}
>
>
>
>
>
>
>
--
This message was sent by Atlassian Jira
(v8.3.4#803005)