Matthias J. Sax created KAFKA-10316:
---------------------------------------
Summary: Consider renaming getter method for Interactive Queries
Key: KAFKA-10316
URL: https://issues.apache.org/jira/browse/KAFKA-10316
Project: Kafka
Issue Type: Improvement
Components: streams
Reporter: Matthias J. Sax
In the 2.5 release, we introduce new classes for Interactive Queries via
KIP-535 (cf https://issues.apache.org/jira/browse/KAFKA-6144). The KIP did not
specify the names for getter methods of `KeyQueryMetadata` explicitly and they
were added in the PR as `getActiveHost()`, `getStandbyHosts()`, and
`getPartition()`.
However, in Kafka it is custom to not use the `get` prefix for getters and thus
the methods should have been added as `activeHost()`, `standbyHosts()`, and
`partition()`, respectively.
We should consider renaming the methods accordingly, by deprecating the
existing ones and adding the new ones in parallel.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)