Omnia Ibrahim created KAFKA-16638:
-------------------------------------
Summary: Align the naming convention for config and default
variables in *Config classes
Key: KAFKA-16638
URL: https://issues.apache.org/jira/browse/KAFKA-16638
Project: Kafka
Issue Type: Task
Reporter: Omnia Ibrahim
Some classes in the code is violating the naming naming convention for config,
doc, and default variables which is:
* `_CONFIG` suffix for defining the configuration
* `_DEFAULT` suffix for default value
* `_DOC` suffix for doc
The following classes need to be updated
* `CleanerConfig` and `RemoteLogManagerConfig` to use `_CONFIG` suffix
instead of `_PROP`.
* Others like `LogConfig` and `QuorumConfig` to use `_DEFAULT` suffix instead
of `DEFAULT_` prefix .
* same goes with `CommonClientConfigs`, `StreamsConfig` however these are
public interfaces and will need a KIP to rename the default value variables and
mark the old one as deprecated. This might need to be broken to different Jira.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)