[ 
https://issues.apache.org/jira/browse/KAFKA-3121?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Guozhang Wang updated KAFKA-3121:
---------------------------------
    Description: 
>From some collected feedbacks, here is a list of potential improvements that 
>we want to make:

1. Remove AggregateSupplier for aggregate, and provide more built-in 
aggregations.

2. Join to return KeyValue<>.

3. "Windows" class syntax-sugers.

4. Add print() to KTable / KStream.

5. flatMap / flatMapValues to return arrays in addition to Iterable.

6. make the API function names aligned with Java 8+, e.g. filterOut -> filterNot

7. collapse process() and transform() in KStream.

8. validate Streaming configs and allow passing properties to KafkaStreaming.  
[DONE]

9. Rename KafkaStreaming to Streams.  [DONE]

Also move some of the state package into internals, and create a new top-level 
common folder with KeyValue / etc in it.

  was:
>From some collected feedbacks, here is a list of potential improvements that 
>we want to make:

1. Remove AggregateSupplier for aggregate, and provide more built-in 
aggregations.

2. Join to return KeyValue<>.

3. "Windows" class syntax-sugers.

4. Add print() to KTable / KStream.

5. flatMap / flatMapValues to return arrays in addition to Iterable.

6. make the API function names aligned with Java 8+, e.g. filterOut -> filterNot

7. collapse process() and transform() in KStream.

8. validate Streaming configs and allow passing properties to KafkaStreaming.

9. Rename KafkaStreaming to Streams.

Also move some of the state package into internals, and create a new top-level 
common folder with KeyValue / etc in it.


> KStream DSL API Improvement
> ---------------------------
>
>                 Key: KAFKA-3121
>                 URL: https://issues.apache.org/jira/browse/KAFKA-3121
>             Project: Kafka
>          Issue Type: Sub-task
>            Reporter: Guozhang Wang
>            Assignee: Guozhang Wang
>
> From some collected feedbacks, here is a list of potential improvements that 
> we want to make:
> 1. Remove AggregateSupplier for aggregate, and provide more built-in 
> aggregations.
> 2. Join to return KeyValue<>.
> 3. "Windows" class syntax-sugers.
> 4. Add print() to KTable / KStream.
> 5. flatMap / flatMapValues to return arrays in addition to Iterable.
> 6. make the API function names aligned with Java 8+, e.g. filterOut -> 
> filterNot
> 7. collapse process() and transform() in KStream.
> 8. validate Streaming configs and allow passing properties to KafkaStreaming. 
>  [DONE]
> 9. Rename KafkaStreaming to Streams.  [DONE]
> Also move some of the state package into internals, and create a new 
> top-level common folder with KeyValue / etc in it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to