Joel Koshy created KAFKA-4362:
---------------------------------
Summary: Offset commits fail after a partition reassignment
Key: KAFKA-4362
URL: https://issues.apache.org/jira/browse/KAFKA-4362
Project: Kafka
Issue Type: Bug
Affects Versions: 0.10.1.0
Reporter: Joel Koshy
Assignee: Jiangjie Qin
When a consumer offsets topic partition reassignment completes, an offset
commit shows this:
{code}
java.lang.IllegalArgumentException: Message format version for partition 100
not found
at
kafka.coordinator.GroupMetadataManager$$anonfun$14.apply(GroupMetadataManager.scala:633)
~[kafka_2.10.jar:?]
at
kafka.coordinator.GroupMetadataManager$$anonfun$14.apply(GroupMetadataManager.scala:633)
~[kafka_2.10.jar:?]
at scala.Option.getOrElse(Option.scala:120) ~[scala-library-2.10.4.jar:?]
at
kafka.coordinator.GroupMetadataManager.kafka$coordinator$GroupMetadataManager$$getMessageFormatVersionAndTimestamp(GroupMetadataManager.scala:632)
~[kafka_2.10.jar:?]
at
...
{code}
The issue is that the replica has been deleted so the
{{GroupMetadataManager.getMessageFormatVersionAndTimestamp}} throws this
exception instead which propagates as an unknown error.
Unfortunately consumers don't respond to this and will fail their offset
commits.
One workaround in the above situation is to bounce the cluster - the consumer
will be forced to rediscover the group coordinator.
(Incidentally, the message incorrectly prints the number of partitions instead
of the actual partition.)
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)