Hi. Sorry I did not respond sooner.
We are currently in the middle of getting ready to do a large reconfigure
of jobs in the CI cluster. Generally, doing more with Ubuntu-14 and CentOS-7.1,
and doing less with Ubuntu-12 (and phasing out CentOS-6.4).
It is a bit too late to add more into this batch, but as I'm going through the
current set of modifications, I will look at what is required to do more CI
jobs for contrail-neutron-plugin.
The two gaps I see for us (CI team) to resolve:
1. Not sure if current set of tempest tests will exercise neutron-plugin
2. CI currently uses controller/ci_unittests.json to determine unit-tests to
run, but currently there is no entries for neutron-plugin.
I am in Sunnyvale next week. I will use my ability to do forced interrupts to
sit with Ajay and resolve above.
On Jul 9, 2015, at 2:23 AM, Numan Siddique <[email protected]> wrote:
> Hello All,
>
> Thanks to the Ajay and Open Contrail community review team, the patch which
> we had submitted [1] to re-factor the vnc_openstack code and to move this to
> contrail neutron plugin (NeutronPluginContrailCoreV3) is merged now [2].
>
> This version of the plugin (NeutronPluginContrailCoreV3)
> - talks to the Vnc Api Server directly using the vnc_api.
> - has improvement on the performance
> - has the code readability and
> - the unit test frame work.
>
>
> We request the user and developer community to try this new plugin so that it
> gets better tested.
> This plugin can be enabled by modifying the "core_plugin" value in the
> neutron.conf as shown below
>
> core_plugin =
> neutron_plugin_contrail.plugins.opencontrail.contrail_plugin_v3.NeutronPluginContrailCoreV3.
>
> @Karl and the OpenContrail CI team - Presently the "contrail-neutron-plugin"
> runs very few tests.
> It would be really great if it is possible to enable tempest job and to run
> Unit tests for this repo.
>
> Also I would request the community to make adding Unit tests mandatory for
> the patches submitted on this repo.
>
>
> [1] - https://review.opencontrail.org/#/c/11280/
> [2] -
> https://github.com/Juniper/contrail-neutron-plugin/commit/352a19a9b77b65e77ee546c30f2d34e30d61d878
>
> Thanks and Regards
> Cloudwatt team
>
>
>
> On 04/13/2015 01:12 PM, Numan Siddique wrote:
>> Hello dev team,
>>
>> We (Cloudwatt) are working on refactoring the vnc_openstack code. The reason
>> we are doing this activity is because
>> - to optimize some code - particularly related to listing of resources
>> (net-list, port-list etc) as presently it is taking lot of time
>> and this can be optimized.
>>
>> - presently there are not much unit tests. By refactoring and reorganizing
>> the code, we can add unit tests to cover various scenarios and data paths.
>>
>> - to make the code more organized so that maintaining could be easier.
>>
>>
>> The code is here [1] and it is work in progress. We wanted to know the
>> community's opinion/thoughts/comments/criticism on this activity. So please
>> let us know the same.
>>
>> [1] -
>> https://github.com/cloudwatt/contrail-controller/tree/vnc_openstack_refactor/src/config/vnc_openstack/vnc_openstack
>>
>>
>> Thanks
>> Numan
--
Klash
_______________________________________________
Dev mailing list
[email protected]
http://lists.opencontrail.org/mailman/listinfo/dev_lists.opencontrail.org