[ 
https://issues.apache.org/jira/browse/LUCENE-2485?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12874687#action_12874687
 ] 

Earwin Burrfoot commented on LUCENE-2485:
-----------------------------------------

bq. w/o this ability, there's no advantage to warming in a hook vs warming 
explicitly after getReader()
There is. Consistency. I understand that this word is not in high regard 
amongst Luceners (progress, not perfection!), but still.
It is logical to have all your warming happen in one defined place. If Lucene 
does magic for you, and biggest part of said warming happens in a separate 
thread without making you wait - that's very nice! But that's just a sideffect, 
like compiler optimizations that may or may not happen.
Also, if your app requires warming for each segment, having a single callback 
frees you from the need to determine for a given new segment returned from 
getReader(), if it is a product of merge and thus already warm, or is it a 
still-cold newly-flushed segment.

> IndexWriter should also warm flushed segments
> ---------------------------------------------
>
>                 Key: LUCENE-2485
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2485
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>            Reporter: Michael McCandless
>             Fix For: 4.0
>
>
> Spinoff of LUCENE-2311.
> You can now set a mergedSegmentWarmer on IW, which warms only newly merged 
> segments.
> But for consistency maybe we should change this to warm all new segments (ie, 
> also flushed ones).  We should rename it to something "setSegmentWarmer".
> Really, the reader pool should be pulled out of IndexWriter, be externally 
> provided, and be responsible for doing warming of new segments.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to