[ 
https://issues.apache.org/jira/browse/SOLR-5466?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13918083#comment-13918083
 ] 

Varun Thacker commented on SOLR-5466:
-------------------------------------

I was thinking we could have something like what Shalin mentioned in a comment 
- 

For example:
{noformat}
/admin/collections?action=STATUS
{noformat}
The above should return all the status info from the cluster. 

{noformat}
/admin/collections?action=STATUS&collection=collection1
{noformat}
The above returns info only about collection1 and its shards (including their 
properties)

{noformat}
/admin/collections?action=STATUS&collection=collection1&shard=shard1,shard2,shard3...
{noformat}
The above returns info only about collection1 and the specified shards 
(including their properties)

along with something like
{noformat}
/admin/collections?action=STATUS&fl=name
{noformat}

This would list only collection names 

or

{noformat}
/admin/collections?action=STATUS&fl=name,router,replicationFactor
{noformat}

This would list only collection names and other details specified.

Basically leverage the "fl" syntax ( we could call it something else also ) to 
ask for only specific information like -
-name
-slices
-activeSlices
-router
-shards
-maxShardsPerNode
-router
-replicationFactor

etc.

bq. And, I started to untangle the fact that we have all the strings in 
OverseerCollectionProcessor, but also have a nice CollectionAction enum. And 
the commands are intermingled with parameters, it all seems rather confusing. 
Does it make sense to use the enum rather than the strings? Or somehow 
associate the two? Probably something for another JIRA though...

Even I found this confusing. We should use either one right?



> Add List Collections functionality to Collections API
> -----------------------------------------------------
>
>                 Key: SOLR-5466
>                 URL: https://issues.apache.org/jira/browse/SOLR-5466
>             Project: Solr
>          Issue Type: Sub-task
>          Components: scripts and tools, SolrCloud
>         Environment: All
>            Reporter: Dave Seltzer
>            Assignee: Shalin Shekhar Mangar
>            Priority: Minor
>              Labels: api, collections, rest
>         Attachments: SOLR-5466.patch, SOLR-5466.patch, SOLR-5466.patch, 
> SOLR-5466.patch
>
>
> The collections API lets you add, delete and modify existing collections. At 
> the moment the API does not let you get a list of current collections or view 
> information about a specific collection.
> The workaround is the use the Zookeeper API to get the list. This makes the 
> Collections API harder to work with. 
> Adding an action=LIST would significantly improve the function of this API.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to