[ 
https://issues.apache.org/jira/browse/LUCENE-5487?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13926114#comment-13926114
 ] 

Michael McCandless commented on LUCENE-5487:
--------------------------------------------

Thanks Rob!

bq. In this case no problem, but just as an FYI, if you have trunk/ and 
branch/, you always want to run the differ outside of both (this way the patch 
prefixes are the same: this one cant be applied by any patch tool).

I actually did that at first but for some reason I thought the resulting patch 
file was wrong!  Next time I'll do it like that.

bq. docs for Weight.scoresDocsOutOfOrder() should refer to bulkScorer() instead 
of scorer()

Oh yeah, I'll fix.

bq. a TODO should be added for BooleanWeight.scoresDocsOutOfOrder

I fixed this and added a simple test, on the branch.

bq. should FakeScorer really not take the real Weight anymore? I don't know how 
useful it is, but its wierd that its null, since the Collector actually sees 
this thing via setScorer: if its not going to be supported then i think it 
should override getWeight to explicitly throw UOE?

It seems weird returning a real Weight when everything else is fake, but I 
guess we can just leave it as it was (in BooleanQuery)?  All the other 
FakeScorers seem to do the null Weight thing, but I agree if we do that we 
should just override getWeight to throw UOE.

bq. what is the purpose of a LeapFrogBulkScorer? It seems to just use two 
in-order scorers, i dont understand its purpose. Is this supposed to be a code 
specialization? 

It was there before, but I think it's just code specialization ... I'll just 
nuke it and let Weight.bulkScorer do the default impl.

> Can we separate "top scorer" from "sub scorer"?
> -----------------------------------------------
>
>                 Key: LUCENE-5487
>                 URL: https://issues.apache.org/jira/browse/LUCENE-5487
>             Project: Lucene - Core
>          Issue Type: Improvement
>          Components: core/search
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 4.8, 5.0
>
>         Attachments: LUCENE-5487.patch, LUCENE-5487.patch, LUCENE-5487.patch
>
>
> This is just an exploratory patch ... still many nocommits, but I
> think it may be promising.
> I find the two booleans we pass to Weight.scorer confusing, because
> they really only apply to whoever will call score(Collector) (just
> IndexSearcher and BooleanScorer).
> The params are pointless for the vast majority of scorers, because
> very, very few query scorers really need to change how top-scoring is
> done, and those scorers can *only* score top-level (throw throw UOE
> from nextDoc/advance).  It seems like these two types of scorers
> should be separately typed.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to