Had to make a minor change in ES to support this refactor (no biggie). Having fresh eyes and curiosity I thought I'd ask what the reason is behind this variable name, 'maxDoc', if deletes are not taken into consideration? Its a bit of a confusing variable and method name.
- SegmentInfo.maxDoc() vs getDocCount() Nicholas Knize
- Re: SegmentInfo.maxDoc() vs getDocCount() Michael McCandless
