Christine Poerschke created SOLR-8114:
-----------------------------------------

             Summary: Grouping.java: sort variable names confusion
                 Key: SOLR-8114
                 URL: https://issues.apache.org/jira/browse/SOLR-8114
             Project: Solr
          Issue Type: Wish
            Reporter: Christine Poerschke
            Assignee: Christine Poerschke
            Priority: Minor


The undistributed case i.e. {{solr/Grouping.java}}'s variable names confusingly 
differ from the names used by lucene (and by the distributed case).

Specifically the name {{groupSort}} in lucene (and in the distributed case) 
means between-groups-sort but in the Grouping.java it means within-group-sort.

lucene:

{code}
TermFirstPassGroupingCollector(... Sort groupSort ...)
TermSecondPassGroupingCollector(... Sort groupSort, Sort withinGroupSort ...)
{code}

solr:

{code}
SearchGroupsFieldCommand.java: firstPassGroupingCollector = new 
TermFirstPassGroupingCollector(field.getName(), groupSort, topNGroups);
TopGroupsFieldCommand.java: secondPassCollector = new 
TermSecondPassGroupingCollector(... groupSort, sortWithinGroup ...);

Grouping.java:    public Sort groupSort;   // the sort of the documents 
*within* a single group.
Grouping.java:    public Sort sort;        // the sort between groups
Grouping.java:  firstPass = new TermFirstPassGroupingCollector(groupBy, sort, 
actualGroupsToFind);
Grouping.java: secondPass = new TermSecondPassGroupingCollector(... sort, 
groupSort ...);
{code}

This JIRA proposes to rename the Grouping.java variables to remove the 
confusion:
 * part 1: in Grouping.java rename groupSort to withinGroupSort
 * part 2: in Grouping.java rename sort to groupSort



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to