There is nothing more I hate than bikeshedding. So, here we go

I'm gonna remove the getKey(), getValue() from pair and replace them with
fist() and second(). No deprecation or anything.
if anyone has any objection, please raise your hand and go ahead with your
preferred names. I can live with any name because we have enough instances
in Solr where naming is totally screwed up and I have managed to maintain
my sanity all these years.

Cheers

On Thu, May 5, 2016 at 8:15 AM, Scott Blum <dragonsi...@gmail.com> wrote:

> Thanks Hoss, I think I just spit coffee all over my keyboard :D
>
> Sometimes you just gotta grow a Pair API.
>
> On Wed, May 4, 2016 at 2:29 PM, Chris Hostetter <hossman_luc...@fucit.org>
> wrote:
>
>>
>> Or maybe methodWithFuckingJavadocsExplainingItsExistence() and
>>
>> otherMethodWIthJavadocsSoUsersDontHaveToGuessIfThereIsADiffBetweenGetKeyAnd_1()
>>
>> how do those method names sound?
>>
>>
>> : Date: Wed, 4 May 2016 14:26:41 -0400
>> : From: Scott Blum <dragonsi...@gmail.com>
>> : Reply-To: dev@lucene.apache.org
>> : To: dev@lucene.apache.org
>> : Subject: Re: lucene-solr:master: added a couple of extra methods
>> :
>> : Or left() and right()
>> :
>> : On Wed, May 4, 2016 at 2:18 PM, Ishan Chattopadhyaya <
>> : ichattopadhy...@gmail.com> wrote:
>> :
>> : > Another option to consider could be: first() and second()
>> : >
>> : > C++ uses it: http://www.cplusplus.com/reference/utility/pair/
>> : >
>> : > On Wed, May 4, 2016 at 11:44 PM, Noble Paul <noble.p...@gmail.com>
>> wrote:
>> : >
>> : >> The names getKey() and getValue() are not always relevant for a pair
>> : >> object. it's not necessarily a key and value. In that case, it makes
>> sense
>> : >> to use the index .
>> : >>
>> : >>
>> : >> This is a convention followed Scala. Tuple2 (
>> : >> http://www.scala-lang.org/api/rc2/scala/Tuple2.html ) to Tuple10 (
>> : >> http://www.scala-lang.org/api/rc2/scala/Tuple10.html)
>> : >>
>> : >> On Wed, May 4, 2016 at 4:32 AM, Chris Hostetter <
>> hossman_luc...@fucit.org
>> : >> > wrote:
>> : >>
>> : >>>
>> : >>> WTF is this?
>> : >>>
>> : >>> why are these (poorly named) alternatives for getKey and getValue
>> useful?
>> : >>>
>> : >>>
>> : >>> : Date: Tue,  3 May 2016 15:09:08 +0000 (UTC)
>> : >>> : From: no...@apache.org
>> : >>> : Reply-To: dev@lucene.apache.org
>> : >>> : To: comm...@lucene.apache.org
>> : >>> : Subject: lucene-solr:master: added a couple of extra methods
>> : >>> :
>> : >>> : Repository: lucene-solr
>> : >>> : Updated Branches:
>> : >>> :   refs/heads/master 0ebe6b0f7 -> 184da9982
>> : >>> :
>> : >>> :
>> : >>> : added a couple of extra methods
>> : >>> :
>> : >>> :
>> : >>> : Project: http://git-wip-us.apache.org/repos/asf/lucene-solr/repo
>> : >>> : Commit:
>> : >>> http://git-wip-us.apache.org/repos/asf/lucene-solr/commit/184da998
>> : >>> : Tree:
>> http://git-wip-us.apache.org/repos/asf/lucene-solr/tree/184da998
>> : >>> : Diff:
>> http://git-wip-us.apache.org/repos/asf/lucene-solr/diff/184da998
>> : >>> :
>> : >>> : Branch: refs/heads/master
>> : >>> : Commit: 184da9982c55fac4735abf01607e4f8f70eb5749
>> : >>> : Parents: 0ebe6b0
>> : >>> : Author: Noble Paul <noble.p...@gmail.com>
>> : >>> : Authored: Tue May 3 20:34:36 2016 +0530
>> : >>> : Committer: Noble Paul <noble.p...@gmail.com>
>> : >>> : Committed: Tue May 3 20:34:36 2016 +0530
>> : >>> :
>> : >>> :
>> ----------------------------------------------------------------------
>> : >>> :  solr/solrj/src/java/org/apache/solr/common/util/Pair.java | 8
>> ++++++++
>> : >>> :  1 file changed, 8 insertions(+)
>> : >>> :
>> ----------------------------------------------------------------------
>> : >>> :
>> : >>> :
>> : >>> :
>> : >>>
>> http://git-wip-us.apache.org/repos/asf/lucene-solr/blob/184da998/solr/solrj/src/java/org/apache/solr/common/util/Pair.java
>> : >>> :
>> ----------------------------------------------------------------------
>> : >>> : diff --git
>> a/solr/solrj/src/java/org/apache/solr/common/util/Pair.java
>> : >>> b/solr/solrj/src/java/org/apache/solr/common/util/Pair.java
>> : >>> : index 423f94c..f87323c 100644
>> : >>> : --- a/solr/solrj/src/java/org/apache/solr/common/util/Pair.java
>> : >>> : +++ b/solr/solrj/src/java/org/apache/solr/common/util/Pair.java
>> : >>> : @@ -27,6 +27,14 @@ public class Pair<K, V> implements
>> Serializable {
>> : >>> :
>> : >>> :    private V value;
>> : >>> :
>> : >>> : +  public K _1() {
>> : >>> : +    return key;
>> : >>> : +  }
>> : >>> : +
>> : >>> : +  public V _2() {
>> : >>> : +    return value;
>> : >>> : +  }
>> : >>> : +
>> : >>> :    public V getValue() {
>> : >>> :      return value;
>> : >>> :    }
>> : >>> :
>> : >>> :
>> : >>>
>> : >>> -Hoss
>> : >>> http://www.lucidworks.com/
>> : >>>
>> : >>>
>> ---------------------------------------------------------------------
>> : >>> To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
>> : >>> For additional commands, e-mail: dev-h...@lucene.apache.org
>> : >>>
>> : >>>
>> : >>
>> : >>
>> : >> --
>> : >> -----------------------------------------------------
>> : >> Noble Paul
>> : >>
>> : >
>> : >
>> :
>>
>> -Hoss
>> http://www.lucidworks.com/
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
>> For additional commands, e-mail: dev-h...@lucene.apache.org
>>
>>
>


-- 
-----------------------------------------------------
Noble Paul

Reply via email to