[ 
https://issues.apache.org/jira/browse/SOLR-8029?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15438801#comment-15438801
 ] 

ASF subversion and git services commented on SOLR-8029:
-------------------------------------------------------

Commit 327aaffae4bd32df6f591a5a3c823ad19fb18df5 in lucene-solr's branch 
refs/heads/apiv2 from [~noble.paul]
[ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=327aaff ]

SOLR-8029 : Addressing a few feedback back comments by steve. The rest to 
follow
 


*        "int" is used instead of "integer" in schemas (json-schema requires 
"integer")

*  JsonSchemaValidator has no "integer" support, only "number" (e.g. no INTEGER 
in JsonSchemaValidator.Type, ApiBag.KNOWN_TYPES)

*  JsonSchemaValidator doesn't validate type values - using an invalid type 
gives an NPE instead of a useful error message

*  JsonValidatorTest is incomplete: it should test all supported schema 
validation aspects

*  Did you explore existing JSON validation libraries (instead of implementing 
from scratch)?

*  JsonSchemaValidator

*  Class javadocs should fully describe the limitations it has compared to full 
JSON schema support

*  Type.valdateData() is misspelled, should be validateData()

*  Attribute.validateData is unused, should be removed

*  Attribute class name is too vague - it could be named SchemaNode instead, 
since it represents a node in a JSON schema graph.

*  ObjectAttribute class name is too vague - it could be named SchemaAttribute 
instead, since it is a set of schema object attribute validators 

*  /url/path appears to be an orphan in many *.json files 

* These orphaned spec files should be removed:

* cores.core.Commands.requestRecovery.json (directly specified in 
cores.core.Commands.json)

* cores.json (handled by cores.Status.json)

* cluster.config.Commands.json:

* "delete" command should be removed, since that functionality is covered by 
cluster.config.delete.json

* cluster.security.RuleBasedAuthorization.json:

* /commands/delete-permission:

* "type" key is present twice - "type":"object" should be removed (since it 
should be "int")

* collections.Commands.json:

* description is spelled "Description" (capital "D") but should be lowercase

* description is a copy-paste-o:"The add-field command adds a new field 
definition to your schema."



> Modernize and standardize Solr APIs
> -----------------------------------
>
>                 Key: SOLR-8029
>                 URL: https://issues.apache.org/jira/browse/SOLR-8029
>             Project: Solr
>          Issue Type: Improvement
>    Affects Versions: 6.0
>            Reporter: Noble Paul
>            Assignee: Noble Paul
>              Labels: API, EaseOfUse
>             Fix For: 6.0
>
>         Attachments: SOLR-8029.patch, SOLR-8029.patch, SOLR-8029.patch, 
> SOLR-8029.patch
>
>
> Solr APIs have organically evolved and they are sometimes inconsistent with 
> each other or not in sync with the widely followed conventions of HTTP 
> protocol. Trying to make incremental changes to make them modern is like 
> applying band-aid. So, we have done a complete rethink of what the APIs 
> should be. The most notable aspects of the API are as follows:
> The new set of APIs will be placed under a new path {{/solr2}}. The legacy 
> APIs will continue to work under the {{/solr}} path as they used to and they 
> will be eventually deprecated.
> There are 4 types of requests in the new API 
> * {{/v2/<collection-name>/*}} : Hit a collection directly or manage 
> collections/shards/replicas 
> * {{/v2/<core>/*}} : Hit a core directly or manage cores 
> * {{/v2/cluster/*}} : Operations on cluster not pertaining to any collection 
> or core. e.g: security, overseer ops etc
> This will be released as part of a major release. Check the link given below 
> for the full specification.  Your comments are welcome
> [Solr API version 2 Specification | http://bit.ly/1JYsBMQ]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to