[ 
https://issues.apache.org/jira/browse/LUCENE-8249?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16445499#comment-16445499
 ] 

Alan Woodward commented on LUCENE-8249:
---------------------------------------

Here's an updated patch:
* minFreq() is now maxFreq()
* I fixed SloppyPhraseMatcher#maxFreq to be the sum of the freqs of each child 
postings, on the grounds that each term position can be the first term in at 
most one match.  +1 on changing to a float, I'd missed that comment before 
uploading the new patch, will change it now.
* ExactPhraseMatcher now advances its lead in sync with everything else, which 
simplifies things a lot.
* I removed freq(), and replaced it with sloppyWeight() which returns the 
contribution of the current match to the total sloppy freq - suggestions for a 
better name are welcomed...
* I originally put in MatchesIterator#term so that highlighters could do things 
like keep track of the number of specific terms in a fragment, for scoring.  I 
like the idea of changing it to return a BytesRef[] though, let's do that in a 
followup.

> Add matches to exact PhraseQuery and MultiPhraseQuery
> -----------------------------------------------------
>
>                 Key: LUCENE-8249
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8249
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Alan Woodward
>            Assignee: Alan Woodward
>            Priority: Major
>         Attachments: LUCENE-8249.patch, LUCENE-8249.patch, LUCENE-8249.patch
>
>
> ExactPhraseScorer can be rejigged fairly easily to expose a MatchesIterator



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to