[
https://issues.apache.org/jira/browse/LUCENE-3470?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Chris Male reassigned LUCENE-3470:
----------------------------------
Assignee: Chris Male
> reorder arguments of Field constructor to be more intuitive
> -----------------------------------------------------------
>
> Key: LUCENE-3470
> URL: https://issues.apache.org/jira/browse/LUCENE-3470
> Project: Lucene - Java
> Issue Type: Task
> Reporter: Robert Muir
> Assignee: Chris Male
> Fix For: 4.0
>
> Attachments: LUCENE-3470.patch
>
>
> I think Field should take (name, value, type) not (name, type, value) ?
> This seems more intuitive and consistent with previous releases
> Take this change to some code I had for example:
> {noformat}
> - d1.add(new Field("foo", "bar", Field.Store.YES, Field.Index.ANALYZED));
> + d1.add(new Field("foo", TextField.TYPE_STORED, "bar"));
> {noformat}
> I think it would be better if it was
> {noformat}
> document.add(new Field("foo", "bar", TextField.TYPE_STORED));
> {noformat}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]