[ 
https://issues.apache.org/jira/browse/LUCENE-3760?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Shai Erera reopened LUCENE-3760:
--------------------------------


Sorry guys for not following the issue more closely. We use 
IndexReader.getCommitUserData in many places across our code.

One place is when we addIndexes(Directory). We have a need to merge the input 
Directory's commit data with the target index's commit data. Since we use the 
optimized writer.addIndexes method, it is a waste to open an IndexReader to 
retrieve the commit data.

Another place is where we just need to read the commit data to extract 
information, without actually needing an IndexReader instance.

In short, this method is very useful to us, and I don't see the advantage of 
making it deprecated. I don't mind if we move it to a DirectoryUtil class if it 
bothers anyone that it's on IndexReader.

We don't use IndexReader.getVersion so I don't mind if it becomes deprecated, 
but I wonder, if there's no real advantage, what's the harm of keeping it?
                
> Cleanup DR.getCurrentVersion/DR.getUserData/DR.getIndexCommit().getUserData()
> -----------------------------------------------------------------------------
>
>                 Key: LUCENE-3760
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3760
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 3.6, 4.0
>
>         Attachments: LUCENE-3760.patch, LUCENE-3760.patch
>
>
> Spinoff from Ryan's dev thread "DR.getCommitUserData() vs 
> DR.getIndexCommit().getUserData()"... these methods are confusing/dups right 
> now.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to