[
https://issues.apache.org/jira/browse/LUCENE-4515?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13489138#comment-13489138
]
Michael McCandless commented on LUCENE-4515:
--------------------------------------------
Maybe rename "maxBufferedBytes" to "maxReusedBytes"? (Because it says how many
bytes can be retained even after reset is called).
I still don't like bringing allocation issues (even a long maxReusedBytes) into
our APIs: this is Java. But since this is package private I guess it's OK.
Can we default it to 0 not 5 MB? I think on reset() it's very unexpected that
this class would still hold onto 5 MB RAM ...
Why does reset() pass true for reuseFirst...?
> Make MemoryIndex more memory efficient
> --------------------------------------
>
> Key: LUCENE-4515
> URL: https://issues.apache.org/jira/browse/LUCENE-4515
> Project: Lucene - Core
> Issue Type: Improvement
> Components: modules/other
> Affects Versions: 4.0, 4.1, 5.0
> Reporter: Simon Willnauer
> Fix For: 4.1, 5.0
>
> Attachments: LUCENE-4515.patch, LUCENE-4515.patch, LUCENE-4515.patch
>
>
> Currently MemoryIndex uses BytesRef objects to represent terms and holds an
> int[] per term per field to represent postings. For highlighting this creates
> a ton of objects for each search that 1. need to be GCed and 2. can't be
> reused.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]