[ 
https://issues.apache.org/jira/browse/LUCENE-2540?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13655743#comment-13655743
 ] 

Greg Bowyer commented on LUCENE-2540:
-------------------------------------

Outside of batch adding fields it looks like this issue is somewhat dead since 
we can now address the field(s) by name, and have sensible iterators on them?

Anyone opposed to closing this ?
                
> Document. add get(i) and addAll to make interacting with fieldables and 
> documents easier/faster and more readable
> -----------------------------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-2540
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2540
>             Project: Lucene - Core
>          Issue Type: Improvement
>          Components: core/other
>    Affects Versions: 3.0.2
>            Reporter: Woody Anderson
>              Labels: dead
>             Fix For: 4.4
>
>         Attachments: LUCENE-2540.patch
>
>
> Working with Document Fieldables is often a pain.
> getting the ith involves chained method calls and is not very readable:
> {code}
> // nice
> doc.getFieldable(i);
> // not nice
> doc.getFields().get(i);
> {code}
> also, when combining documents, or otherwise aggregating multiple fields into 
> a single document,
> {code}
> // nice
> doc.addAll(fieldables);
> // note nice: less readable and more error prone
> List<Fieldable> fields = ...;
> for (Fieldable field : fields) {
>   result.add(field);
> }
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to