[ 
https://issues.apache.org/jira/browse/LUCENE-5157?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13729531#comment-13729531
 ] 

Boaz Leskes commented on LUCENE-5157:
-------------------------------------

I agree with the principle however the current implementation was already using 
segments in the API. For example:

public long getSegmentOrd(int subIndex, long globalOrd)

In which I removed the first parameter which was not used and renamed it to:

public long getFirstSegmentOrd(long globalOrd)

this to communicate the segment of which you get the ordinal.



                
> Refactoring MultiDocValues.OrdinalMap to clarify API and internal structure.
> ----------------------------------------------------------------------------
>
>                 Key: LUCENE-5157
>                 URL: https://issues.apache.org/jira/browse/LUCENE-5157
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Boaz Leskes
>            Priority: Minor
>         Attachments: LUCENE-5157.patch
>
>
> I refactored MultiDocValues.OrdinalMap, removing one unused parameter and 
> renaming some methods to more clearly communicate what they do. Also I 
> renamed subIndex references to segmentIndex.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to