-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/3147/#review3874
-----------------------------------------------------------



/trunk/core/src/main/java/org/apache/mahout/math/hadoop/DistributedRowMatrix.java
<https://reviews.apache.org/r/3147/#comment8701>

    I would really rather use standard terminology here.
    
    A mean row is a row that is that average of all others, but a row mean 
would mean an average of the elements a single row.  The plural form, row 
means, indicates the means of all rows.  What you are computing are the means 
of every column.
    
    In contrast, R, Octave and Matlab all use columnMeans as the name of the 
function being implemented here.



/trunk/core/src/main/java/org/apache/mahout/math/hadoop/MatrixRowMeanJob.java
<https://reviews.apache.org/r/3147/#comment8702>

    There are lots of lines with trailing white space.  Isn't this easily 
suppressed?


- Ted


On 2011-12-13 04:46:47, Raphael Cendrillon wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/3147/
> -----------------------------------------------------------
> 
> (Updated 2011-12-13 04:46:47)
> 
> 
> Review request for mahout, lancenorskog and Dmitriy Lyubimov.
> 
> 
> Summary
> -------
> 
> Here's a patch with a simple job to calculate the row mean (column-wise 
> mean). One outstanding issue is the combiner, this requires a wrtiable class 
> IntVectorTupleWritable, where the Int stores the number of rows, and the 
> Vector stores the column-wise sum.
> 
> 
> This addresses bug MAHOUT-923.
>     https://issues.apache.org/jira/browse/MAHOUT-923
> 
> 
> Diffs
> -----
> 
>   
> /trunk/core/src/main/java/org/apache/mahout/math/hadoop/DistributedRowMatrix.java
>  1213474 
>   
> /trunk/core/src/main/java/org/apache/mahout/math/hadoop/MatrixRowMeanJob.java 
> PRE-CREATION 
>   
> /trunk/core/src/test/java/org/apache/mahout/math/hadoop/TestDistributedRowMatrix.java
>  1213474 
> 
> Diff: https://reviews.apache.org/r/3147/diff
> 
> 
> Testing
> -------
> 
> Junit test
> 
> 
> Thanks,
> 
> Raphael
> 
>

Reply via email to