-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/16147/#review32209
-----------------------------------------------------------

Ship it!


Good stuff! A couple of style nits and request for comments :)


src/Makefile.am
<https://reviews.apache.org/r/16147/#comment60924>

    The '\''s should be aligned. The tabstop for Makefiles is 8.



src/Makefile.am
<https://reviews.apache.org/r/16147/#comment60925>

    Again, can you indent the '\' to align with the others.



src/Makefile.am
<https://reviews.apache.org/r/16147/#comment60926>

    And here.



src/Makefile.am
<https://reviews.apache.org/r/16147/#comment60927>

    And here.



src/local/local.cpp
<https://reviews.apache.org/r/16147/#comment61053>

    Wrap line.



src/local/local.cpp
<https://reviews.apache.org/r/16147/#comment61054>

    Wrap line.



src/local/local.cpp
<https://reviews.apache.org/r/16147/#comment61055>

    Wrap line.



src/slave/container/containerizer.hpp
<https://reviews.apache.org/r/16147/#comment61010>

    s/class/struct/



src/slave/container/containerizer.hpp
<https://reviews.apache.org/r/16147/#comment60933>

    Kill new line?



src/slave/container/containerizer.hpp
<https://reviews.apache.org/r/16147/#comment61235>

    Can you merge this fetch() into the one above? Or are you using this 
fetch() somewhere else? At least the two sharing name and having different 
semantics was confused us a bit :)



src/slave/container/containerizer.hpp
<https://reviews.apache.org/r/16147/#comment60932>

    Kill newline?



src/slave/container/containerizer.cpp
<https://reviews.apache.org/r/16147/#comment61240>

    Can we skip this for now? We'll extend ::create() with the pluggable 
containerizer review.



src/slave/container/containerizer.cpp
<https://reviews.apache.org/r/16147/#comment61211>

    Not yours, but can we wrap this way:
    
    bool chmodded =
      os::chmod(fetched.get(), S_IRWXU | S_IRGRP | S_IXGRP | S_IROTH | S_IXOTH);
    
    or another way pointed out by the style guide?



src/slave/container/external_containerizer.hpp
<https://reviews.apache.org/r/16147/#comment61013>

    Can we move ExternalContainerizer to its own review i.e. kill this file 
from this review?



src/slave/container/mesos_containerizer.cpp
<https://reviews.apache.org/r/16147/#comment61245>

    Why is the semaphore optional?



src/slave/container/mesos_containerizer.cpp
<https://reviews.apache.org/r/16147/#comment61249>

    Is this async signal safe?



src/slave/container/mesos_containerizer.cpp
<https://reviews.apache.org/r/16147/#comment61243>

    Can you wrap and indent? So it becomes:
    
    const map<string, string>& env = executorEnvironment(
        executorInfo,
        directory,
        slaveId,
        slavePid,
        checkpoint);



src/slave/container/mesos_containerizer.cpp
<https://reviews.apache.org/r/16147/#comment61248>

    Why a semaphore instead of a pipe?



src/slave/container/mesos_containerizer.cpp
<https://reviews.apache.org/r/16147/#comment61242>

    Same wrap and indent here.



src/slave/container/mesos_containerizer.cpp
<https://reviews.apache.org/r/16147/#comment61250>

    Can you add a comment on the flow below? This will also highlight your 
naming scheme.



src/slave/container/mesos_containerizer.cpp
<https://reviews.apache.org/r/16147/#comment61244>

    Does it make sense to delegate reaping to the launcher?



src/slave/container/mesos_containerizer.cpp
<https://reviews.apache.org/r/16147/#comment60930>

    The usual wrap is before ':'



src/slave/monitor.hpp
<https://reviews.apache.org/r/16147/#comment60928>

    s/exectorInfo/executorInfo/



src/slave/slave.cpp
<https://reviews.apache.org/r/16147/#comment61213>

    Mind change this to CopyFrom too?



src/slave/slave.cpp
<https://reviews.apache.org/r/16147/#comment61215>

    Wrap this please.



src/slave/slave.cpp
<https://reviews.apache.org/r/16147/#comment61222>

    Can you indent on new line? So it becomes:
    
    const string& path = paths::getExecutorRunPath(
       flags.work_dir,
       info.id(),
       framework->id,
       executor->id,
       executor->containerId);



src/slave/slave.cpp
<https://reviews.apache.org/r/16147/#comment61223>

    Wrap please.



src/slave/slave.cpp
<https://reviews.apache.org/r/16147/#comment61225>

    Indent as mentioned above.



src/slave/state.cpp
<https://reviews.apache.org/r/16147/#comment61228>

    Not yours, but can you bring to new line and indent? So it becomes:
    
    return Error(
       "Failed to recover" ...
       " of executor "' ...



src/slave/state.cpp
<https://reviews.apache.org/r/16147/#comment61056>

    Wrap line.



src/slave/status_update_manager.cpp
<https://reviews.apache.org/r/16147/#comment61230>

    Can you swap "->" with "therefore". Or otherwise spell the log string out?


- Niklas Nielsen


On Jan. 21, 2014, 11:36 a.m., Ian Downes wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/16147/
> -----------------------------------------------------------
> 
> (Updated Jan. 21, 2014, 11:36 a.m.)
> 
> 
> Review request for mesos, Benjamin Hindman, Ben Mahler, Chi Zhang, Niklas 
> Nielsen, samya, and Jason Dusek.
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> The proposed Containerizer interface is to replace the existing Isolator. 
> 
> One ContainerizerProcess has been written:
> MesosContainerizerProcess - implements containerizeration internally using a 
> Launcher and one or more Isolators (following review)
> 
> The intent is to also support a generic ExternalContainerizerProcess that can 
> delegate containerizeration by making external calls. Other Containerizers 
> could interface with specific external containerization techniques such as 
> Docker or LXC.
> 
> 
> Diffs
> -----
> 
>   include/mesos/mesos.proto 655f86757487ddbe551fdcf53eb793e773ecdd34 
>   src/Makefile.am cf0c8c66e8dd21c2f5a2da22e5d5adb056353454 
>   src/common/type_utils.hpp 3b05751a9a27055dd19e4abb79197f53e5554fe1 
>   src/launcher/launcher.hpp 104fe812ddd2b75b14ec0b40d192f58cdba3603a 
>   src/launcher/launcher.cpp d5ab66704429a95eeb8eda5188e33d8e691221af 
>   src/launcher/main.cpp de64609905ee63096c0173fe7e64a1eafea5d6bf 
>   src/local/local.cpp 83a7f913afb1441e9137c7fcec8fd81815714905 
>   src/slave/cgroups_isolator.hpp e86062e9abaaa263c32c55e9dbfefd700f605886 
>   src/slave/cgroups_isolator.cpp 80155a3f0cd684a6aad9a37f61c5204d86032735 
>   src/slave/container/containerizer.hpp PRE-CREATION 
>   src/slave/container/containerizer.cpp PRE-CREATION 
>   src/slave/container/external_containerizer.hpp PRE-CREATION 
>   src/slave/container/mesos_containerizer.hpp PRE-CREATION 
>   src/slave/container/mesos_containerizer.cpp PRE-CREATION 
>   src/slave/flags.hpp 827b2d0d6dc8fa279f3187a09e5dc6d4799d17cd 
>   src/slave/http.cpp c8357e214d2adf2cd712072f58d07b07badb79dc 
>   src/slave/isolator.hpp 9634535d8c746597b4bb6e278587a1b9ca8f1608 
>   src/slave/isolator.cpp c9643cf9c5657bc142482a71fb161233bffb3b9f 
>   src/slave/main.cpp e0cae7b205c2599e05c4db990cc9c8e9e3673c37 
>   src/slave/monitor.hpp 52568ad8ec566f7cf36c249c76d798d44eacb578 
>   src/slave/monitor.cpp a931c4f35a8793c66ee03de82f0e0a21b92f8ffa 
>   src/slave/paths.hpp b1a56a346ca84e7e71c31386602264c5097ef1cf 
>   src/slave/process_isolator.hpp 4ae093fe65775a2b9bec42071961dd58aa0c3d8b 
>   src/slave/process_isolator.cpp 0bc698f04f7c8eaad166dc9d646e13310129dd01 
>   src/slave/slave.hpp 38ba7b6d6c35f0668d2f021a1285363cbf4367f4 
>   src/slave/slave.cpp 8b83dacad802a5434bf76ca075b2b8113ed14a84 
>   src/slave/state.hpp 78b20ffae1f2f629d851784302648e3bf5349321 
>   src/slave/state.cpp 93cde0c2efbbe5387448631a02e64b20a3d021c1 
>   src/slave/status_update_manager.hpp 
> 06ea4659cdd24cb1b82f389f404566ba14a663fb 
>   src/slave/status_update_manager.cpp 
> 03f5eafefd6ed748bfd4511d654c23c7b460db66 
> 
> Diff: https://reviews.apache.org/r/16147/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Ian Downes
> 
>

Reply via email to