[ https://issues.apache.org/jira/browse/FTPSERVER-195?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12639205#action_12639205 ]
Emmanuel Lecharny commented on FTPSERVER-195: --------------------------------------------- Makes sense ! Can you provide a patch for such a modification ? When it's obvious, simply applying a patch is certainly faster than modifying the code > Some boolean properties of FtpFile are not accessibile with the JavaBean > isFoo() > -------------------------------------------------------------------------------- > > Key: FTPSERVER-195 > URL: https://issues.apache.org/jira/browse/FTPSERVER-195 > Project: FtpServer > Issue Type: Bug > Reporter: Andrea Francia > > We have three properties that do not follow the JavaBean convention: > public interface FtpFile { > boolean hasReadPermission(); > boolean hasWritePermission(); > boolean hasDeletePermission(); > ... > } > They could be renamed as > public interface FtpFile { > boolean isReadable(); > boolean isWritable(); > boolean isRemovable(); > ... > } > Using the JavaBean convetion for properties allow interoperability with code > that uses bean introspection to access to object classes. -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online.