[ https://issues.apache.org/jira/browse/DIRMINA-823?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13006821#comment-13006821 ]
Emmanuel Lecharny commented on DIRMINA-823: ------------------------------------------- I read you. Howerver, again, there is no difference between putInt() and putUnsignedInt(). In fact, the message I wanted to convey is that the getUnsignedXXX methods have a very specific semantic : to guarantee that we cast a value into a bigger container (getUnsignedInt stores the value into a long), and the semantic of such a method is really wrong, IMHO. Should we continue to walk this path, just because the initial API has (again, IMHO) decided to provide some semantically wrong methods ? (note that I didn't rejected the issue, I just try to get a clear opinion about this one. Adding the requested methods would be a matter of minutes) > Add IoBuffer.putUnsigned* methods to balance the getUnsigned* methods for > completeness > -------------------------------------------------------------------------------------- > > Key: DIRMINA-823 > URL: https://issues.apache.org/jira/browse/DIRMINA-823 > Project: MINA > Issue Type: Improvement > Components: Core > Affects Versions: 2.0.2 > Environment: WXP SP3, Sun SDK 1.5 > Reporter: Francis ANDRE > Priority: Trivial > > While unsigned integers types are quite meaningful in networking protocols, > Java does not provide unsigned integer primitive types. The > IoBuffer.getUnsigned* methods are filling the gap between the need of > unsigned integers and the real Java programs. > But IoBuffer does not provide the correlative IoBuffer.putUnsigned* methods. > Thus for completeness, this issue proposes to add those IoBuffer.putUnsigned* > methods. > Rgds -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira