-1
Sorry, I cannot agree.

The API doc of resetValue() tells you why:
"Convenience method to reset [..]"

A "utility like" method for convenience like this one does not belong
to an interface. It does not add any behavioural function.
UIInput is not an interface but a (base) class, so it is ok to have
such a method there.

Matze, do you have any concrete use case that could confirm your POV?

--Manfred


On Jan 15, 2008 7:22 AM, Matthias Wessendorf <[EMAIL PROTECTED]> wrote:
> Hi,
>
> the resetValue() method was added directly to UIinput, instead to a
> proper interface (EditableValueHolder).
> I guess this was done, to not break impls of that interface.
> IMO this is wrong and should (at least in JSF2) be part of the
> EditableValueHolder interface.
>
> Since JSF2 will bring much more new bits, such an "enhancement" on the
> interface might be valueable.
>
> What is your take on that ?
>
> -Matthias
>
> --
> Matthias Wessendorf
>
> further stuff:
> blog: http://matthiaswessendorf.wordpress.com/
> sessions: http://www.slideshare.net/mwessendorf
> mail: matzew-at-apache-dot-org
>

Reply via email to