What to do about lines of code like this:
...
# define GPIO_CNF_INPULLDWN (2 << GPIO_CNF_SHIFT) /* Input
pull-down */
# define GPIO_CNF_INPULLUP ((2 << GPIO_CNF_SHIFT) | GPIO_OUTPUT_SET)
/* Input pull-up */
...
I would probably fix that like:
# define GPIO_CNF_INPULLDWN (2 << GPIO_CNF_SHIFT) /* Input
pull-down */
# define GPIO_CNF_INPULLUP ((2 << GPIO_CNF_SHIFT) | \
GPIO_OUTPUT_SET) /* Input
pull-up */
Or
# define GPIO_CNF_INPULLDWN (2 << GPIO_CNF_SHIFT) /* Input
pull-down */
# define GPIO_CNF_INPULLUP ((2 << GPIO_CNF_SHIFT) | GPIO_OUTPUT_SET)
/* Input
pull-up */