Hi,

I'd like to refactor the names of the test services for the credit card processor, because in my opinion, the existing names are confusing. However I have some doubts/questions.

For example the auth services are:

*Auth services*

testCCProcessor
testCCProcessorWithCapture
testRandomAuthorize
alwaysApproveCCProcessor
alwaysApproveWithCaptureCCProcessor
alwaysDeclineCCProcessor
alwaysNsfCCProcessor
alwaysBadExpireCCProcessor
badExpireEvenCCProcessor

I'd suggest to use the following naming convention:

testCCProcessorAuth*
(so that we can distinguish them from the testCCProcessorCapture* ones)

For example:
testCCProcessorAuthAlwaysApprove (was alwaysApproveCCProcessor)
testCCProcessorAuthAlwaysDecline (was alwaysDeclineCCProcessor)
testCCProcessorAuthAlwaysNsfDecline (was alwaysNsfCCProcessor)
testCCProcessorAuthAlwaysBadExpireDecline (was alwaysBadExpireCCProcessor)
etc...

What do you think?
My question is: what is the intended use of alwaysApproveWithCaptureCCProcessor (and testCCProcessorWithCapture)? I really don't understand for what they are used for?

Thanks,

Jacopo

Reply via email to