Adrian,

One question and one demand to follow best practice for mini-lang after the overhaul.

Question :
Before I have in a scipt :

      <entity-condition entity-name="PartyRelationship" 
list="widget.partyRelationList">
           <condition-list>
             <condition-expr field-name="partyIdFrom" operator="equals" 
from-field="parameters.partyId" ignore="${'FROM'!=widget.relationIs}"/>
             <condition-expr field-name="partyIdTo" operator="equals" 
from-field="parameters.partyId" ignore="${'FROM'==widget.relationIs}"/>

With last change, it generate a grammar error, so  I have change to

      <set field="relationIsNotFrom" from="'FROM'!=widget.relationIs"/>
      <set field="relationIsFrom" from="'FROM'==widget.relationIs"/>
      <entity-condition entity-name="PartyRelationship" 
list="widget.partyRelationList">
           <condition-list>
             <condition-expr field-name="partyIdFrom" operator="equals" 
from-field="parameters.partyId" ignore="${relationIsNotFrom}"/>
             <condition-expr field-name="partyIdTo" operator="equals" 
from-field="parameters.partyId" ignore="${relationIsFrom}"/>

Question: is it correct ? or you think there is a more readable way

Demand : currently, each time I modify or write a mini-lang file I try to use only the "not deprecated" tag and attribute, but it will be more easy if a simple-methods-target.xsd exist, it will contain only the "non deprecated" tag and attribute.
That do you think about it?

Reply via email to