It's a peculiar case (license header then just below function doc.). 
It was just annoying me to think that somebody using the same JS editor than me 
in Eclipse would not see this function documentation by default (it  has much 
arguments).

Jacques

On Sunday, January 05, 2014 3:53 PM, adrian.c...@sandglass-software.com wrote
> So now we format code to suit a particular editor? Are we going to move
> the comments in all JS functions, or only the ones that don't look right
> in your editor?
> 
> Adrian Crum
> Sandglass Software
> www.sandglass-software.com
> 
> On 1/5/2014 9:31 AM, jler...@apache.org wrote:
>> Author: jleroux
>> Date: Sun Jan  5 14:31:46 2014
>> New Revision: 1555516
>> 
>> URL: http://svn.apache.org/r1555516
>> Log:
>> Unfortunately adding a line is not enough for Aptana js editor to separate 
>> comments, so better to put comments in the function
>> itself 
>> 
>> 
>> Modified:
>>      ofbiz/trunk/framework/images/webapp/images/miscAjaxFunctions.js
>> 
>> Modified: ofbiz/trunk/framework/images/webapp/images/miscAjaxFunctions.js
>> URL:
>> http://svn.apache.org/viewvc/ofbiz/trunk/framework/images/webapp/images/miscAjaxFunctions.js?rev=1555516&r1=1555515&r2=1555516&view=diff
>> ==============================================================================
>>  ---
>> ofbiz/trunk/framework/images/webapp/images/miscAjaxFunctions.js (original) 
>> +++
>> ofbiz/trunk/framework/images/webapp/images/miscAjaxFunctions.js Sun Jan  5 
>> 14:31:46 2014 @@ -16,8 +16,9 @@
>>    * specific language governing permissions and limitations
>>    * under the License.
>>    */
>> -
>> -// *** getDependentDropdownValues allows to dynamically populate a 
>> dependent drop-down on change on its parent drop-down,
>> doesn't require any fixed naming convention +
>> +function getDependentDropdownValues(request, paramKey, paramField, 
>> targetField, responseName, keyName, descName, selected,
>> callback, allowEmpty, hide, hideTitle, inputField){ +// To dynamically 
>> populate a dependent drop-down on change on its parent
>>   drop-down, doesn't require any fixed naming convention // request      = 
>> request calling the service which retrieve the info
>>   from the DB, ex: getAssociatedStateList // paramKey     = parameter value 
>> used in the called service
>>   // paramField   = parent drop-down field Id (mainId)
>> @@ -31,10 +32,9 @@
>>   // hide         = optional boolean argument, if true the dependent 
>> drop-down field (targetField) will be hidden when no
>>   options are available else only disabled. False by default. // hideTitle   
>>  = optional boolean argument (hide must be set to
>>   true), if true the title of the dependent drop-down field (targetField) 
>> will be hidden when no options are available else
>> only disabled. False by default. // inputField   = optional name of an input 
>> field 
>> -//           this is to handle a specific case where an input field is 
>> needed instead of a drop-down when no values are
>> returned by the request 
>> -//           this will be maybe extended later to use an auto-completed 
>> drop-down or a lookup, instead of straight drop-down
>> currently, when there are too much values to populate 
>> -//           this is e.g. currently used in the Product Price Rules screen
>> -function getDependentDropdownValues(request, paramKey, paramField, 
>> targetField, responseName, keyName, descName, selected,
>> callback, allowEmpty, hide, hideTitle, inputField){ +//             this is 
>> to handle a specific case where an input field is
>> needed instead of a drop-down when no values are returned by the request +// 
>>             this will be maybe extended later to
>> use an auto-completed drop-down or a lookup, instead of straight drop-down 
>> currently, when there are too much values to
>>       populate +//             this is e.g. currently used in the Product 
>> Price Rules screen target = '#' + targetField;
>>       input = '#' + inputField;
>>       targetTitle = target + '_title'

Reply via email to