There are indeed some data model inconsistencies in this area.
After reviewing the commit (817605) that introduced the field productWeight
I think that the following applies:
"weight" should be used to specify the "shipping weight" of the product
"productWeight" should be used to specify the actual weight of the product.

However since its introduction, productWeight was never used and "weight"
has been used both to specify the shipping weight and to specify the actual
weight.

How can we fix this situation? I see two options:
1) review all usages of "weight" and fix according to the definition above
2) rename "productWeight" into "shippingWeight" and fix the codebase to use
this field only when the shipping weight is required and use "weight" in
all the other cases.

Maybe #2 would be easier to implement and would have a limited impact on
existing instances.

Jacopo



On Tue, Dec 15, 2015 at 12:03 PM, Suraj Khurana <
suraj.khur...@hotwaxsystems.com> wrote:

> Hello all,
>
> Hope you are doing good.
>
> There are three sets of dimensions in the Product entity.
> (productHeight, shippingHeight), (productWidth,  shippingWidth),
> (productDepth,
> shippingDepth) which all makes perfect sense to user.
> But in case of another dimension i.e. weight, there is another set of
> dimension fields weight and productWeight in Product entity.
> When I dig into the framework code weight field is more used when we are
> talking about actual product weight and productWeight field is not used
> anywhere.
> Also, there is no field such as shippingWeight.
> Can someone please put some more light on this and explain the exact use of
> productWeight field and what is the exact way to store shippingWeight of a
> product on Product level.
> Thanks in advance.
>
> --
> Best Regards,
> Suraj Khurana
> Enterprise Software Engineer
> HotWax Systems <http://www.hotwaxsystems.com/> - *The global leader in
> innovative enterprise commerce solutions **powered by Apache OFBiz.*
> <https://about.me/surajkhurana?promo=email_sig>
>

Reply via email to