[ 
https://issues.apache.org/jira/browse/OOZIE-2020?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14582325#comment-14582325
 ] 

Srikanth Sundarrajan commented on OOZIE-2020:
---------------------------------------------

Is it intentional that succeeded action’s can’t be re-run through this filter 
or is it an oversight ? Also it might help to call this something else, 
FILTERSTATUS appears like a generic collection of statuses that can be used for 
filter. Why not use COMPLETED_COORD_ACTION_STATUSES, which seems more 
appropriate.
{code}
+    public enum FILTERSTATUS {KILLED, FAILED, TIMEDOUT};
{code}
If you do consider all actions in completed status for re-run consider renaming 
GET_TERMINATED* in JPA modules to GET_COMPLETED* ?

{{LocalOozieClientCoord}}
Should we have a different error code instead for input checks ?
{code}
throw new CommandException(ErrorCode.E1018, "Invalid value provided for filter 
option; " +
        "Valid Value is 
'status=KILLED;status=FAILED;status=TIMEDOUT'");

{code}

{{V1JobsServlet}}
parseFilters is redundantly implemeented in two places in the server. Possible 
to reconcile ?

{{TestCoordRerunXCommand}}

why not checking for waiting in this case as in others ?
{code}
assertNotSame(action2.getStatus(), CoordinatorAction.Status.SUCCEEDED);
{code} 

Few nits:
* Plenty of unused imports introduced in the patch
* Few unused variables
* javadoc incorrect:: CoordUtils
* Use logger instead of print stack trace to SysErr (LocalOozieClientCoord)
* Error message in OozieCLI isn't consistent with other invalid input exceptions

> Rerun all Failed/killed/timedout coordinator actions rather than specifying 
> action numbers
> ------------------------------------------------------------------------------------------
>
>                 Key: OOZIE-2020
>                 URL: https://issues.apache.org/jira/browse/OOZIE-2020
>             Project: Oozie
>          Issue Type: New Feature
>          Components: action
>            Reporter: Sreedish P S
>            Assignee: Narayan Periwal
>            Priority: Minor
>         Attachments: OOZIE-2020-v10.patch, OOZIE-2020-v11.patch, 
> OOZIE-2020-v12.patch, OOZIE-2020-v13.patch, OOZIE-2020-v14.patch, 
> OOZIE-2020-v15.patch, OOZIE-2020-v16.patch, OOZIE-2020-v17.patch, 
> OOZIE-2020-v8.patch, OOZIE-2020-v9.patch
>
>
> Currently rerun of coordinator actions are made through coordinator id and 
> action numbers, this feature request is for rerunning all coordinator actions 
> by mentioning a particular state
> for example :
> oozie job -rerun coord-id -state killed



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to