[
https://issues.apache.org/jira/browse/OOZIE-3262?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Andras Piros updated OOZIE-3262:
--------------------------------
Description:
Similar to the text fixture
{{TestSparkArgsExtractor#testPropertiesArePrependedToSparkArgs()}} covered by
OOZIE-3228, extend the usage of {{assertContainsSublist()}} for every other
test case as well.
This has some advantages:
* test runs become more stable when parameterized differently
* code gets more readable
* {{assert}} only what's necessary instead of always the whole Spark argument
list. For most test cases it's not needed
was:
Similar to the text fixture
{{TestSparkArgsExtractor#testPropertiesArePrependedToSparkArgs}} covered by
OOZIE-3228, extend the usage of {{assertContainsSublist()}} for every other
test case as well.
This has some advantages:
* test runs become more stable when parameterized differently
* code gets more readable
* {{assert}} only what's necessary instead of always the whole Spark argument
list. For most test cases it's not needed
> [Spark action] Improve TestSparkArgsExtractor
> ---------------------------------------------
>
> Key: OOZIE-3262
> URL: https://issues.apache.org/jira/browse/OOZIE-3262
> Project: Oozie
> Issue Type: Improvement
> Components: tests
> Affects Versions: 5.0.0
> Reporter: Andras Piros
> Priority: Major
>
> Similar to the text fixture
> {{TestSparkArgsExtractor#testPropertiesArePrependedToSparkArgs()}} covered by
> OOZIE-3228, extend the usage of {{assertContainsSublist()}} for every other
> test case as well.
> This has some advantages:
> * test runs become more stable when parameterized differently
> * code gets more readable
> * {{assert}} only what's necessary instead of always the whole Spark argument
> list. For most test cases it's not needed
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)