I thought this was in here already, but I guess not. Signed-off-by: Ben Pfaff <b...@nicira.com> --- CodingStyle | 5 +++++ 1 file changed, 5 insertions(+)
diff --git a/CodingStyle b/CodingStyle index 0ba0366..628f21f 100644 --- a/CodingStyle +++ b/CodingStyle @@ -162,6 +162,11 @@ such a function (including the C standard library function free()) should omit a null-pointer check. We find that this usually makes code easier to read. +Functions in .c files should not normally be marked "inline", because +it does not usually help code generation and it does suppress +compilers warnings about unused functions. (Functions defined in .h +usually should be marked inline.) + FUNCTION PROTOTYPES -- 1.7.10.4 _______________________________________________ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev