>
>On 09.08.2016 18:02, Mark Kavanagh wrote:
>> Add support for Jumbo Frames to DPDK-enabled port types,
>> using single-segment-mbufs.
>>
>> Using this approach, the amount of memory allocated to each mbuf
>> to store frame data is increased to a value greater than 1518B
>> (typical Ethernet maximum frame length). The increased space
>> available in the mbuf means that an entire Jumbo Frame of a specific
>> size can be carried in a single mbuf, as opposed to partitioning
>> it across multiple mbuf segments.
>>
>> The amount of space allocated to each mbuf to hold frame data is
>> defined dynamically by the user with ovs-vsctl, via the 'mtu_request'
>> parameter.
>>
>> Signed-off-by: Mark Kavanagh <mark.b.kavan...@intel.com>
>> [diproiet...@vmware.com rebased]
>> Signed-off-by: Daniele Di Proietto <diproiet...@vmware.com>
>> ---
>>
>> v6:
>>     - include device name in netdev_dpdk_set_mtu error log
>>     - resolve minor coding standards infractions
>>
>> v5:
>>     - rename dpdk_mp_configure to netdev_dpdk_mempool_configure
>>     - consolidate socket_id and mtu changes within
>>       netdev_dpdk_mempool_configure
>>     - add lower bounds check for user-supplied MTU
>>     - add socket_id and mtu fields to mempool configure error report
>>     - minor cosmetic changes
>>
>> v4:
>>     - restore error reporting in *_reconfigure functions (for
>>       non-mtu-configuration based errors)
>>     - remove 'goto' in the event of dpdk_mp_configure failure
>>     - remove superfluous error variables
>>
>>  v3:
>>     - replace netdev_dpdk.last_mtu with local variable
>>     - add comment for dpdk_mp_configure
>>
>>  v2:
>>      - rebase to HEAD of master
>>      - fall back to previous 'good' MTU if reconfigure fails
>>      - introduce new field 'last_mtu' in struct netdev_dpdk to facilitate
>>        fall-back
>>      - rename 'mtu_request' to 'requested_mtu' in struct netdev_dpdk
>>      - remove rebasing artifact in INSTALL.DPDK-Advanced.md
>>      - remove superflous variable in dpdk_mp_configure
>>      - fix minor coding style infraction
>>
>>
>>  INSTALL.DPDK-ADVANCED.md |  58 ++++++++++++++++++-
>>  INSTALL.DPDK.md          |   1 -
>>  NEWS                     |   1 +
>>  lib/netdev-dpdk.c        | 145 
>> +++++++++++++++++++++++++++++++++++++++--------
>>  4 files changed, 176 insertions(+), 29 deletions(-)
>
>Looks good to me.
>You may add one of this tags:
>
>Signed-off-by: Ilya Maximets <i.maxim...@samsung.com>
>Acked-by: Ilya Maximets <i.maxim...@samsung.com>
>
>Choose which of them is more suitable.

I added you as 'Signed-off-by' - thanks for all of your review comments and 
contributions to this patch!

Cheers,
Mark

>
>Best regards, Ilya Maximets.
_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to