I'd like to remove some of the static functions which work on/return a COSArray 
from COSArrayList and move these to COSArray.

For 2.x I'd deprecate them. In 3.0 I'd remove them.

Sample of currently used code

 public static COSArray convertStringListToCOSNameCOSArray( List<String> 
strings )
    {
        COSArray retval = new COSArray();
        for (String string : strings)
        {
            retval.add(COSName.getPDFName(string));
        }
        return retval;
    }

As one can see - there is no relation to COSArrayList

Method naming could propably also be simplified a bit such as 
COSArray.withCOSNames

WDYT?

BR
Maruan


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@pdfbox.apache.org
For additional commands, e-mail: dev-h...@pdfbox.apache.org

Reply via email to