Good points ....
Am 03.04.20, 16:12 schrieb "Bjoern Hoeper" <[email protected]>:
Hi,
in my opinion the runtime is the more relevant thing in this context
because if you take a .NET Lib you could use it with VB or F# or any other
language that is compatible with the .NET Runtime. So the language is only the
language in which it is written (which could also be intermixed). Furthermore
it is quite common to use something like NET e.g. log4j had an equivalent of
log4net.
Björn
-----Ursprüngliche Nachricht-----
Von: Christofer Dutz <[email protected]>
Gesendet: Freitag, 3. April 2020 15:43
An: [email protected]
Betreff: [DISCUSS] Rename PLC4DOTNET to PLC4CSHARP?
Hi,
I just wanted to bring this to discussion … I have now encountered in
several projects that support different languages that the naming convention we
follow seems to match:
* C : xyz_c
* C++: xyz_cpp
* Python: xyz_py
However when it comes to C# we sort of named it “plc4dotnet” … I would
propose to change it to “plc4csharp” as this is the language … “dotnet” is sort
of more the runtime.
What do you think?
Chris