[
https://issues.apache.org/jira/browse/PROTON-2977?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Andrew Stitcher resolved PROTON-2977.
-------------------------------------
Resolution: Fixed
> Delivery tags are not limited to 32 bytes
> -----------------------------------------
>
> Key: PROTON-2977
> URL: https://issues.apache.org/jira/browse/PROTON-2977
> Project: Qpid Proton
> Issue Type: Bug
> Components: proton-c
> Reporter: Andrew Stitcher
> Assignee: Andrew Stitcher
> Priority: Major
>
> When creating deliveries using pn_delivery() you can specify a tag more then
> 32 bytes long and it will be accepted and used on the wire. This means that
> you can create semantically valid but illegal protocol frames.
> Since this is a long standing error in the proton implementation it would be
> best if we don't suddenly start erroring pn_delivery() calls that previously
> succeeded, but we also shouldn't create illegal protocol frames. IT'll
> probably be best to truncate illegal tags to 32 bytes long.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]