[ 
https://issues.apache.org/jira/browse/PROTON-1180?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15246654#comment-15246654
 ] 

ASF subversion and git services commented on PROTON-1180:
---------------------------------------------------------

Commit a5db6a1edc3c804de1bc59b512b3879e1329bb40 in qpid-proton's branch 
refs/heads/master from [~astitcher]
[ https://git-wip-us.apache.org/repos/asf?p=qpid-proton.git;h=a5db6a1 ]

PROTON-1180: [C++ binding] endpoint changes:
- Implement boolean state predicates:
  - uninitialized(),
  - local_active(), remote_active()
  - closed()
- These are the only ones used in the current code,
  but may still need a bit of consideration
- Raised close() to endpoint class
  - Needed to implement session::close() as it was never used
    so we didn't notice it wasn't implemented!


> [C++ binding] Change endpoint API
> ---------------------------------
>
>                 Key: PROTON-1180
>                 URL: https://issues.apache.org/jira/browse/PROTON-1180
>             Project: Qpid Proton
>          Issue Type: Improvement
>            Reporter: Andrew Stitcher
>            Assignee: Andrew Stitcher
>
> * Rename remote_condition to condition; remove local_condition (the remote 
> state is authoritative)
> * Add boolean accessors for uninitialized, active, and closed; remove 
> endpoint.state bit field
> * Lift close operation to endpoint from its descendents
> * Add new close operation with condition arg



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@qpid.apache.org
For additional commands, e-mail: dev-h...@qpid.apache.org

Reply via email to