[ 
https://issues.apache.org/jira/browse/RANGER-1916?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

peng.jianhua updated RANGER-1916:
---------------------------------
    Description: 
Remove duplicate code and optimize code in AtlasClient.class
The follow code
“if (client != null) {
                                client.destroy();
                        }” 
 in connectionTestResource  and connectionTestResource method has  been 
declared in the run () method that called them ,so remove duplicate code,And 
change the code "AtlasClient AtlasClient = null;" to "AtlasClient atlasClient = 
null;"

  was:
Remove duplicate code and optimize code in AtlasClient.class
The follow code in connectionTestResource  and connectionTestResource method 
has  been declared in the run () method that called them ,so remove duplicate 
code,And change the code "AtlasClient AtlasClient = null;" to "AtlasClient 
atlasClient = null;"


> Remove duplicate code and optimize code in AtlasClient.class
> ------------------------------------------------------------
>
>                 Key: RANGER-1916
>                 URL: https://issues.apache.org/jira/browse/RANGER-1916
>             Project: Ranger
>          Issue Type: Improvement
>          Components: plugins
>    Affects Versions: master
>            Reporter: peng.jianhua
>            Assignee: peng.jianhua
>            Priority: Minor
>             Fix For: master
>
>
> Remove duplicate code and optimize code in AtlasClient.class
> The follow code
> “if (client != null) {
>                               client.destroy();
>                       }” 
>  in connectionTestResource  and connectionTestResource method has  been 
> declared in the run () method that called them ,so remove duplicate code,And 
> change the code "AtlasClient AtlasClient = null;" to "AtlasClient atlasClient 
> = null;"



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to