On Tue, Jul 13, 2010 at 12:14 PM, <[email protected]> wrote: > While I think this is a fairly common use case, I'm negative on adding > the method. > > Adding ~50 bytes to gadgets.core so developers can call > > {{{ > gadgets.util.getContainer() > }}} > > instead of > {{{ > gadgets.util.getUrlParameters().container > }}} > > doesn't seem worth it to me - especially considering that if there are > any extra url parameters the user might want to access in the future > it's more methods to add (and provide legacy support for). > > If documentation is the issue, then documenting "getUrlParameters()" > would be easier IMO. > > (not sure if I've missed some discussion on this) >
Nope, this thread _is_ the discussion, so I'm happy for your input ;) The value I see isn't necessarily in avoiding .container, it's instead: A) the other two: synd || "default" B) the flexibility to change the URL scheme later or on a per-installation basis. For instance, the security token often contains the container ID -- using it would save bytes. A container ID could also be injected by the server, or the param could be renamed. It's all really just a hedge though ;) --j > > Tim > > > http://codereview.appspot.com/1760044/show >
