[ 
https://issues.apache.org/jira/browse/SLIDER-526?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14187681#comment-14187681
 ] 

thomas liu edited comment on SLIDER-526 at 10/28/14 11:43 PM:
--------------------------------------------------------------

The patch is a little hard to read. Basically the content of the script looks 
like:
''comments..."

this= " $ {BASH_SOURCE-$0} "
bindir= $ (cd -P -- " $(dirname --  " $this " ) " && pwd -P)

python $ {bindir}/slider.py " $ @ "

(some space added to be well formatted by JIRA)

Tested with unit test cases, fun test cases
I also created a symbolic link under /usr/bin as 'slider' which point to the 
slider shell script built under my workspace

It seems to work with MacOS/Linux but not Centos6.4. Is this a understood 
issue? The error doesn't seem to be from the refactoring in this ticket
exception 'NoneType' object has no attribute 'rfind' from line 161 of 
Slider.py: 
exe = subprocess.Popen(commandline,
                        stdin=None,
                        stdout=subprocess.PIPE,
                        stderr=subprocess.PIPE,
                        shell=False,
                        bufsize=1, 
                        close_fds=ON_POSIX)



was (Author: thomas_liu):
The patch is a little hard to read. Basically the content of the script looks 
like:
''comments..."

this="${BASH_SOURCE-$0}"
bindir=$(cd -P -- "$(dirname -- "$this")" && pwd -P)

python ${bindir}/slider.py "$@"

Tested with unit test cases, fun test cases
I also created a symbolic link under /usr/bin as 'slider' which point to the 
slider shell script built under my workspace

It seems to work with Python 2.7 but not 2.6.6. Is this a understood issue? The 
error doesn't seem to be from the refactoring in this ticket
exception 'NoneType' object has no attribute 'rfind' from line 161 of 
Slider.py: 
exe = subprocess.Popen(commandline,
                        stdin=None,
                        stdout=subprocess.PIPE,
                        stderr=subprocess.PIPE,
                        shell=False,
                        bufsize=1, 
                        close_fds=ON_POSIX)


> Replace slider shell script with slider.py and rename it slider
> ---------------------------------------------------------------
>
>                 Key: SLIDER-526
>                 URL: https://issues.apache.org/jira/browse/SLIDER-526
>             Project: Slider
>          Issue Type: Bug
>          Components: client
>    Affects Versions: Slider 0.50
>            Reporter: Sumit Mohanty
>            Assignee: thomas liu
>             Fix For: Slider 0.60
>
>         Attachments: slider526.patch, slider526.patch, slider526.patch
>
>
> The goal is to have a single python script that can work on Windows and Linux 
> and also be able to call commands directly "e..g slider list" without having 
> to say "python slider list". Of course "python slider list" should also work.
> Lets try to make name change on a linux environment and see what issues, if 
> any, we run into.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to