[
https://issues.apache.org/jira/browse/SLIDER-1112?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15251076#comment-15251076
]
Gour Saha commented on SLIDER-1112:
-----------------------------------
There is a lot of duplicated code in the 001 patch. We should overload the
existing function createTemplatedSliderApplication by adding a new 6th boolean
param failOnError say (with default of true). Then modify the if condition line
as follows -
{code}
int returnCode = shell.execute()
if (failOnError && 0 != returnCode) {
{code}
Then call this utility from
testCreateApplicationWithOneAddonPackagesForNoComponents with an additional
false argument at the end. All other tests which use this function will not be
affected.
> ApplicationWithAddonPackagesIT.testCreateApplicationWithOneAddonPackagesForNoComponents
> fails in Windows
> --------------------------------------------------------------------------------------------------------
>
> Key: SLIDER-1112
> URL: https://issues.apache.org/jira/browse/SLIDER-1112
> Project: Slider
> Issue Type: Improvement
> Components: test
> Reporter: thomas liu
> Assignee: thomas liu
> Fix For: Slider 0.91
>
> Attachments: slider-1112-001.patch
>
>
> Create a separate createTemplatedSliderApplication utility function and let
> testCreateApplicationWithOneAddonPackagesForNoComponents use that
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)